Creating a bootable USB drive from an ISO is pretty easy on Windows, but you end up going to the terminal on macOS. Not a big deal if you remember all the commands. Since it seems like I’m frequently installing something (Linux, Windows 10, etc.) on a different I thought I would make a quick blog post listing the steps for next time.
- First convert the ISO into a disk image for macOS.
- Then rename it to .img
- Use diskutil to find the target USB drive
- Unmount the USB drive and write the img file
- Eject the USB drive
hdiutil convert -format UDRW -o targetfile.dmg sourcefile.iso mv targetfile.dmg targetfile.img diskutil list diskutil unmountDisk /dev/disk4 sudo dd if=Desktop/targetfile.img of=/dev/rdisk4 bs=1m diskutil eject /dev/disk4
I usually get an error from macOS when I’m done about not being able to read the USB disk. It is also fairly quick too.